const regex = /('Your )(.*?)( were successfully )(<strong>edited<\/strong>\.')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\'Your )(.*?)( were successfully )(<strong>edited<\\\/strong>\\.\')', 'gm')
const str = `'Your package were successfully <strong>edited</strong>.'
'Your group were successfully <strong>edited</strong>.'
'Your subscriber were successfully <strong>edited</strong>.'`;
const subst = `L10n\:\:message\('action.label', array\('action' => L10n\:\:label\('edit'\), 'label' => L10n\:\:label\(MODULE\)\)\)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);