// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)('Your )(.*?)( were successfully )(<strong>edited<\/strong>\.')").unwrap();
let string = "'Your package were successfully <strong>edited</strong>.'
'Your group were successfully <strong>edited</strong>.'
'Your subscriber were successfully <strong>edited</strong>.'";
let substitution = "L10n\\:\\:message\\('action.label', array\\('action' => L10n\\:\\:label\\('edit'\\), 'label' => L10n\\:\\:label\\(MODULE\\)\\)\\)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}