import Foundation
let pattern = #"('Your )(.*?)( were successfully )(<strong>edited<\/strong>\.')"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
'Your package were successfully <strong>edited</strong>.'
'Your group were successfully <strong>edited</strong>.'
'Your subscriber were successfully <strong>edited</strong>.'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"L10n\:\:message\('action.label', array\('action' => L10n\:\:label\('edit'\), 'label' => L10n\:\:label\(MODULE\)\)\)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)