using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=PLUS(?:(?!SC).){29})SC";
string input = @"PLUS This is a AC and this is an SC too
PLUS This is a SC and this is an SC too";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}