package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)미소`)
var str = `더 캄캄한 이곳에 shine like the stars
그 미소를 띠며 I'll kiss you goodbye
실컷 비웃어라 꼴좋으니까
이제 너희 1 2 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}