#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\[\[((?:(?!\[{2}).)*?)SPACE(.*?)]]"
Local $sString = "..text.. [[wordoneSPACE**wordtwo**]] ..moretext.." & @CRLF & _
".. [[ ..text(not to cut).. [[wordone[SPACE]**[wordtwo]**]] ..moretext.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")