$re = '/^([a-z]|\b-\b){1,30}$/m';
$str = 'ababab-asd
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
sssssssssssssssss-s-s-s-sss
sdsds-sd-sd-s-d-sd---sd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);