re = /^([a-z]|\b-\b){1,30}$/m
str = 'ababab-asd
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
sssssssssssssssss-s-s-s-sss
sdsds-sd-sd-s-d-sd---sd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end