import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<timestamp>[\\d\\-\\s\\:]+)\\s\\[(?<threadname>[\\d\\.\\w\\s\\(\\)\\-]+)\\]\\s-\\s(?<loglevel>[\\w]+)\\s+-\\s+(?<systemmsg>[^(?:(?!app\\-info).)*\\s\\.\\w\\-\\'\\:\\d\\[\\]\\/]+)";
final String string = "2018-04-27 10:42:23 [RMI TCP Connection(10)-127.0.0.1] - INFO - org.apache.catalina.core.ContainerBase.[Tomcat].[localhost].[/] - Initializing Spring FrameworkServlet 'dispatcherServlet'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}