const regex = /(?<timestamp>[\d\-\s\:]+)\s\[(?<threadname>[\d\.\w\s\(\)\-]+)\]\s-\s(?<loglevel>[\w]+)\s+-\s+(?<systemmsg>[^(?:(?!app\-info).)*\s\.\w\-\'\:\d\[\]\/]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<timestamp>[\\d\\-\\s\\:]+)\\s\\[(?<threadname>[\\d\\.\\w\\s\\(\\)\\-]+)\\]\\s-\\s(?<loglevel>[\\w]+)\\s+-\\s+(?<systemmsg>[^(?:(?!app\\-info).)*\\s\\.\\w\\-\\\'\\:\\d\\[\\]\\\/]+)', 'gm')
const str = `2018-04-27 10:42:23 [RMI TCP Connection(10)-127.0.0.1] - INFO - org.apache.catalina.core.ContainerBase.[Tomcat].[localhost].[/] - Initializing Spring FrameworkServlet 'dispatcherServlet'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}