const regex = /(?<timestamp>[\d\-\s\:]+)\s\[(?<threadname>[\d\.\w\s\(\)\-]+)\]\s-\s(?<loglevel>[\w]+)\s+-\s+(?<systemmsg>[\s\.\w\-\'\:\d\[\]\/]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<timestamp>[\\d\\-\\s\\:]+)\\s\\[(?<threadname>[\\d\\.\\w\\s\\(\\)\\-]+)\\]\\s-\\s(?<loglevel>[\\w]+)\\s+-\\s+(?<systemmsg>[\\s\\.\\w\\-\\\'\\:\\d\\[\\]\\\/]+)', 'gm')
const str = `2018-04-27 10:42:49 [http-nio-8088-exec-1] - INFO - app-info - injectip ip 192.168.16.89
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}