$re = '/(?<return>return)|(?<other>(?:(?!return)\S)+)/m';
$str = 'return abc 123
;return this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);