$re = '/^(?=.*\d)\w{3,20}$/m';
$str = 'password
2ssasda2s
242342342
fsadf-asf2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);