# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\(\) => import\()'@\/([^']*)'\)/$1\/* webpackChunkName: "$2" *\/ '@\/$2')/gm;t' <<< "() => import('@/components/something/Something')
with
() => import(/* webpackChunkName: \"components--something--Something\" */ '@/components/something/Something')"