$re = '~(\(\) => import\()\'@/([^\']*)\'\)~m';
$str = '() => import(\'@/components/something/Something\')
with
() => import(/* webpackChunkName: "components--something--Something" */ \'@/components/something/Something\')';
$subst = "$1/* webpackChunkName: \"$2\" */ '@/$2')";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;