$re = '/(?<=SAR\s)[\d\,\.]+/m';
$str = 'SAR 0.00,
SAR 1,456,254.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);