$re = '/(.*)((?<=[.!?]\s|^).*?lockbox.*?)(?<=[.!?]|$)(.*)/is';
$str = 'Prickelnder Zitronengeschmack aus Bad Liebenwerda. Abgefüllt in leichte 1,0 Liter PET-Mehrwegflaschen kommt die Zitronenlimonade im 12er Kasten direkt per Lockbox zu dir nach Hause. Heute bestellt, morgen oder zum Wunschtermin auf dem Küchentisch! Lieferung per Lockbox jeweils von Montag bis Freitag.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);