import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a href=\"([^\"]+)\".+img src=\"([^\"]+)";
final String string = "<p style=\"text-align: center;\"><a href=\"/upload/obzor-PG32UQX/\" class=\"fancybox\"><img src=\"/upload/obzor-PG32UQX/01_tab1.png\"></a></p>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}