package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z]{2})\/(?:[a-zA-Z]{2}\/)*(?:[a-zA-Z]{2})\/?$`)
var str = `de/fr/en/de/en
en/fr/en/de/fr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}