re = /^([a-zA-Z]{2})\/(?:[a-zA-Z]{2}\/)*(?:[a-zA-Z]{2})\/?$/m
str = 'de/fr/en/de/en
en/fr/en/de/fr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end