import Foundation
let pattern = #"^(3[6-9]|4[0-3]|3[6-9].[0-9]{1,2}|4[0-2].[0-9]{1,2})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
32
33
34
35
35.9
36
36.2
36.21
36.67
36.42
36.8
37
38
39
39.05
39.34
40
40.01
41
41.3
41.42
41.67
42
42.1
42.25
42.8
43
43.6
44
45
46
47
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)