#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{28}$)(?:[A-Za-z0-9+/]{4})+[A-Za-z0-9+/]{2,3}==?$"
Local $sString = "platformAndroidSignatureHash" & @CRLF & _
"2pmj9i4rSx0yEb/viWBYkE/ZQrk=" & @CRLF & _
"aPz8/NARbPz8pPzg/Iz9aPz8NCg=" & @CRLF & _
"aPz8/NARbPz8pPzg/Iz9aPz8NC==" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")