using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{28}$)(?:[A-Za-z0-9+/]{4})+[A-Za-z0-9+/]{2,3}==?$";
string input = @"platformAndroidSignatureHash
2pmj9i4rSx0yEb/viWBYkE/ZQrk=
aPz8/NARbPz8pPzg/Iz9aPz8NCg=
aPz8/NARbPz8pPzg/Iz9aPz8NC==
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}