const regex = new RegExp('^(.+)(\\@)(\\w+)(\\.)(\\w{3,4})$', 'gm')
const str = `some@email.com
yo@email.com
yoo@email.com
212@yahoo.com
@yahoo.com
moreover@.
superb@.com
yahoo.com@superninja.net
hmmer.com@
some@email.body
superb@new.horizon
super.man.followme@neworld.wow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}