import re
regex = re.compile(r"^(.+)(\@)(\w+)(\.)(\w{3,4})$", flags=re.MULTILINE)
test_str = ("some@email.com\n"
"yo@email.com\n"
"yoo@email.com\n"
"212@yahoo.com\n"
"@yahoo.com\n"
"moreover@.\n"
"superb@.com\n"
"yahoo.com@superninja.net\n"
"hmmer.com@\n"
"some@email.body\n"
"superb@new.horizon\n"
"super.man.followme@neworld.wow")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")