// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+)(\@)(\w+)(\.)(\w{3,4})$").unwrap();
let string = "some@email.com
yo@email.com
yoo@email.com
212@yahoo.com
@yahoo.com
moreover@.
superb@.com
yahoo.com@superninja.net
hmmer.com@
some@email.body
superb@new.horizon
super.man.followme@neworld.wow";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}