package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((https?[^\s]+)\)`)
var str = `**For more: [Click here]$(https://www.google.ca) and [click me]$(https://www.google.com)**
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}