re = /(.+?:[\/\\]+)/
str = 'dec:/file1.texdec:/file2.srcdec:/file3.ltx\\ndec:/file4.dtxdec:/file5.insdec:/file6.src
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end