import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "dark:\\w+?[^\" ]+";
final String string = "<div class=\"bg-white dark:bg-slate-800 rounded-lg px-6 py-8 ring-1 ring-slate-900/5 shadow-xl\">\n"
+ " <div>\n"
+ " <span class=\"inline-flex items-center justify-center p-2 bg-indigo-500 rounded-md shadow-lg\">\n"
+ " <svg class=\"h-6 w-6 text-white\" xmlns=\"http://www.w3.org/2000/svg\" fill=\"none\" viewBox=\"0 0 24 24\" stroke=\"currentColor\" aria-hidden=\"true\"><!-- ... --></svg>\n"
+ " </span>\n"
+ " </div>\n"
+ " <h3 class=\"text-slate-900 dark:text-white mt-5 text-base font-medium tracking-tight\">Writes Upside-Down</h3>\n"
+ " <p class=\"text-slate-500 dark:text-slate-400 mt-2 text-sm\">\n"
+ " <p class=\"text-slate-500 dark:text-slate-400\">\n"
+ " The Zero Gravity Pen can be used to write in any orientation, including upside-down. It even works in outer space.\n"
+ " </p>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}