$re = '/\w+(?=.*:)/m';
$str = 'root/naming-will-look-like-this:1.0.0-SNAP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);