$re = '/((?<=^by ).*(?= \|))|((?<=\| by ).*(?= \|))/m';
$str = 'Part of: Excel For Beginners (3 Books) | by Henry E. Mejia | Apr 4, 2021';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);