#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.java:\d+\)([\r\n]+)\s\S+"
Local $sString = "Total threads: 434 on 2018-04-29T17-00-03+0800" & @CRLF & _
" " & @CRLF & _
" Name CPU Time (ms) User Time (ms) Id State" & @CRLF & _
" IPC Parameter Sending Thread #868 0 0 17782 TIMED_WAITING" & @CRLF & _
" waiting on java.util.concurrent.SynchronousQueue$TransferStack@4d974d1c at sun.misc.Unsafe.park(Native Method)" & @CRLF & _
" at java.util.concurrent.locks.LockSupport.parkNanos(LockSupport.java:215)" & @CRLF & _
" at java.util.concurrent.SynchronousQueue$TransferStack.awaitFulfill(SynchronousQueue.java:460)" & @CRLF & _
" at java.util.concurrent.SynchronousQueue$TransferStack.transfer(SynchronousQueue.java:362)" & @CRLF & _
" at java.util.concurrent.SynchronousQueue.poll(SynchronousQueue.java:941)" & @CRLF & _
" at java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1066)" & @CRLF & _
" at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1127)" & @CRLF & _
" at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)" & @CRLF & _
" at java.lang.Thread.run(Thread.java:745)" & @CRLF & _
" IPC Client (2006835220) connection to abcd.com/10.21.216.71:8020 from hdfs 0 0 17781 TIMED_WAITING" & @CRLF & _
" waiting on org.apache.hadoop.ipc.Client$Connection@5be22c7a at java.lang.Object.wait(Native Method)" & @CRLF & _
" at org.apache.hadoop.ipc.Client$Connection.waitForWork(Client.java:931)" & @CRLF & _
" at org.apache.hadoop.ipc.Client$Connection.run(Client.java:976)" & @CRLF & _
" 1306724746@qtp-695248316-10273 29 10 17780 TIMED_WAITING" & @CRLF & _
" waiting on org.mortbay.thread.QueuedThreadPool$PoolThread@4de3098a at java.lang.Object.wait(Native Method)" & @CRLF & _
" at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:626)" & @CRLF & _
" 2125946201@qtp-695248316-10271 40 20 17776 TIMED_WAITING" & @CRLF & _
" waiting on org.mortbay.thread.QueuedThreadPool$PoolThread@7eb75d59 at java.lang.Object.wait(Native Method)" & @CRLF & _
" at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:626)" & @CRLF & _
" 1805988475@qtp-695248316-10269 133 70 17772 TIMED_WAITING" & @CRLF & _
" waiting on org.mortbay.thread.QueuedThreadPool$PoolThread@6ba5327b at java.lang.Object.wait(Native Method)" & @CRLF & _
" at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:626)" & @CRLF & _
" 402769840@qtp-695248316-10266 161 90 17766 TIMED_WAITING" & @CRLF & _
" waiting on org.mortbay.thread.QueuedThreadPool$PoolThread@1801c7b0 at java.lang.Object.wait(Native Method)" & @CRLF & _
" at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:626)" & @CRLF & _
" FastExecutor-3-60 1 0 17747 WAITING" & @CRLF & _
" waiting on java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject@476f266c at sun.misc.Unsafe.park(Native Method)" & @CRLF & _
" at java.util.concurrent.locks.LockSupport.park(LockSupport.java:175)" & @CRLF & _
" at java.util.concurrent.locks.AbstractQueuedSynchronizer$ConditionObject.await(AbstractQueuedSynchronizer.java:2039)" & @CRLF & _
" at java.util.concurrent.LinkedBlockingQueue.take(LinkedBlockingQueue.java:442)" & @CRLF & _
" at java.util.concurrent.ThreadPoolExecutor.getTask(ThreadPoolExecutor.java:1067)" & @CRLF & _
" at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1127)" & @CRLF & _
" at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)" & @CRLF & _
" at com.xyz.shadow.io.netty.util.concurrent.DefaultThreadFactory$DefaultRunnableDecorator.run(DefaultThreadFactory.java:145)" & @CRLF & _
" at java.lang.Thread.run(Thread.java:745)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")