import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?=(?:.+\\R){4,}.+(?:\\R^$|\\Z)).{4}\\K.{2} | \\G(?=(?:.+\\R){4,}.+(?:\\R^$|\\Z)).+\\K.{2}(?=.{4}$))\n"
+ "| ^(?=(?:.+\\R){3}.+(?:\\R^$|\\Z)).{2} | \\G(?=(?:.+\\R){3}.+(?:\\R^$|\\Z)).+\\K.{2}(?=$)\n"
+ "| ^(?=(?:.+\\R){2}.+(?:\\R^$|\\Z)).\\K.{2} | \\G(?=(?:.+\\R){2}.+(?:\\R^$|\\Z)).+\\K.{2}(?=.$)\n"
+ "| ^(?=(?:.+\\R).+(?:\\R^$|\\Z)).{2}\\K.{2} | \\G(?=(?:.+\\R).+(?:\\R^$|\\Z)).+\\K.{2}(?=.{2}$)\n"
+ "| ^(?=(?:.+(?:\\R^$|\\Z))).{3}\\K.+(?=.{3}(?:\\R^$|\\Z))";
final String string = "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n\n"
+ "sdaffdsdfsdsfaadd\n"
+ "afdsafdsfssdsfdfs\n"
+ "afdsfdssdfdssfdsf\n"
+ "asfddsfafsdfdsdsf\n"
+ "asfdsdfafdsafasdf\n\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}