const regex = /(?:^(?=(?:.+\R){4,}.+(?:\R^$|\Z)).{4}\K.{2} | \G(?=(?:.+\R){4,}.+(?:\R^$|\Z)).+\K.{2}(?=.{4}$))
| ^(?=(?:.+\R){3}.+(?:\R^$|\Z)).{2} | \G(?=(?:.+\R){3}.+(?:\R^$|\Z)).+\K.{2}(?=$)
| ^(?=(?:.+\R){2}.+(?:\R^$|\Z)).\K.{2} | \G(?=(?:.+\R){2}.+(?:\R^$|\Z)).+\K.{2}(?=.$)
| ^(?=(?:.+\R).+(?:\R^$|\Z)).{2}\K.{2} | \G(?=(?:.+\R).+(?:\R^$|\Z)).+\K.{2}(?=.{2}$)
| ^(?=(?:.+(?:\R^$|\Z))).{3}\K.+(?=.{3}(?:\R^$|\Z))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?=(?:.+\\R){4,}.+(?:\\R^$|\\Z)).{4}\\K.{2} | \\G(?=(?:.+\\R){4,}.+(?:\\R^$|\\Z)).+\\K.{2}(?=.{4}$))
| ^(?=(?:.+\\R){3}.+(?:\\R^$|\\Z)).{2} | \\G(?=(?:.+\\R){3}.+(?:\\R^$|\\Z)).+\\K.{2}(?=$)
| ^(?=(?:.+\\R){2}.+(?:\\R^$|\\Z)).\\K.{2} | \\G(?=(?:.+\\R){2}.+(?:\\R^$|\\Z)).+\\K.{2}(?=.$)
| ^(?=(?:.+\\R).+(?:\\R^$|\\Z)).{2}\\K.{2} | \\G(?=(?:.+\\R).+(?:\\R^$|\\Z)).+\\K.{2}(?=.{2}$)
| ^(?=(?:.+(?:\\R^$|\\Z))).{3}\\K.+(?=.{3}(?:\\R^$|\\Z))', 'gm')
const str = `aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}