re = /^[A-zÀ-ÿ ]*\1*,(?:\s)(\w*,\s)(CEP (\d{5}-\d{3}))/im
str = 'Rua das Flores, 123, CEP 60321-105
Avenida Brasil, 456A, CEP 16945-017
Travessa dos Santos, 101, CEP 12345-678
Rua Catarina, 243, CEP 25437-987
Rua Sâo Pedro, 243, cep 25437-987
'
subst = '\\^[A-Za-z ]*\\1*,(?:\\s)(\\w*,\\s)(CEP (\\d{5}-\\d{3}))\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result