import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*\\W|^)bar(\\W.*|$)";
final String string = "Foo | Boolean Result\n\n"
+ "blah bar / boo doo | True\n\n"
+ "but is / should not match | False\n\n"
+ "but match / here bar | True";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}