// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*\W|^)bar(\W.*|$)").unwrap();
let string = "Foo | Boolean Result
blah bar / boo doo | True
but is / should not match | False
but match / here bar | True";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}