// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z0-9]*\?[A-Za-z0-9?]*$").unwrap();
let string = "ABC123?A
1ABCA?
?2ABCD
123?34?
?
but not
ABC123
ABC.?1D1
ABC(a)?1d";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}