package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]{2,}-\d+(?:\([^)]+\))?)\s([a-zA-Z]+\s?[a-zA-Z]+)\s\d*-\d*\s([a-zA-Z]+\s?[a-zA-Z]+\s?[a-zA-Z]+)`)
var str = `Design No. TAHN-7075 Natural Gray 0997-101 White 0911-101
Design No. TAHN-7082(CS-02) Natural Gray 0997-101 Natural Gray 0997-101`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}