const regex = new RegExp('\\(([^)]+)\\)', '')
const str = `(hello)`;
const subst = `pippo`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);