import re
regex = re.compile(r"\(([^)]+)\)")
test_str = "(hello)"
subst = "pippo"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)