import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\s+(?<code>(20[012])).*(action:(?<!read))?";
final String string = "1 200 file:test01.txt, action:read, User:dummy\n"
+ "2 201 file:test01.txt, action:write, User:dummy\n"
+ "3 202 file:unknown, keepalive , User:dummy\n"
+ "4 450 file:test01.txt, action:read, User:dummy\n"
+ "5 500 file:test01.txt, action:read, User:dummy\n"
+ "6 201 profiles, action:reload, User:dummy";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}