use strict;
my $str = '@20dibur@50 sdfgghh.
@20dibur nosaf. end here@50.
@20dibur fsrtt sdfsf@50 sdfgghh.
@20dibur fsrtt F5 sdfsf@50 sdfgghh.
@20dibur fsrtt AF5 sdfsf@50 sdfgghh.
';
my $regex = qr/(?<=@20).*?(?=@50|\.|F5|AF5)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}