#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^[.]+)([.])([^_.]+)_"
Local $sString = "[BillingFunctions.requestGprsTariff]" & @CRLF & _
"[BillingFunctions.requestGprsTariff]" & @CRLF & _
"[BillingFunctions.requestGprsTariff]" & @CRLF & _
"[BillingFunctions.requestSmsTariff]" & @CRLF & _
"[BillingFunctions.requestSmsTariff]" & @CRLF & _
"[BillingFunctions.requestSmsTariff]]" & @CRLF & _
"[BillingFunctions.requestVoiceTariff]" & @CRLF & _
"[BillingFunctions.requestVoiceTariff]" & @CRLF & _
"[BillingFunctions.requestVoiceTariff]" & @CRLF & _
"[GprsGxService.onStart]" & @CRLF & _
"[GprsGxService.onStart]" & @CRLF & _
"[GprsGxService.onStart]" & @CRLF & _
"[GprsGxService.onStart_ACCOUNT_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_ACCOUNT_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_ACCOUNT_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[GprsGxService.onStart_CARD_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_CARD_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_CARD_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_FAKE_NUMBER]" & @CRLF & _
"[GprsGxService.onStart_FAKE_NUMBER]" & @CRLF & _
"[GprsGxService.onStart_FAKE_NUMBER]" & @CRLF & _
"[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]" & @CRLF & _
"[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]" & @CRLF & _
"[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]" & @CRLF & _
"[GprsGxService.onStart_INTERNAL_ERROR]" & @CRLF & _
"[GprsGxService.onStart_INTERNAL_ERROR]" & @CRLF & _
"[GprsGxService.onStart_INTERNAL_ERROR]" & @CRLF & _
"[GprsGxService.onStart_NO_MONEY]" & @CRLF & _
"[GprsGxService.onStart_NO_MONEY]" & @CRLF & _
"[GprsGxService.onStart_NO_MONEY]" & @CRLF & _
"[GprsGxService.onStart_OBJECT_BUSY]" & @CRLF & _
"[GprsGxService.onStart_OBJECT_BUSY]" & @CRLF & _
"[GprsGxService.onStart_OBJECT_BUSY]" & @CRLF & _
"[GprsGxService.onStart_OK]" & @CRLF & _
"[GprsGxService.onStart_OK]" & @CRLF & _
"[GprsGxService.onStart_OK]" & @CRLF & _
"[GprsGxService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGxService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGxService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGxService.onStart_TARIFF_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_TARIFF_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_TARIFF_NOT_FOUND]" & @CRLF & _
"[GprsGxService.onStart_UNSUITABLE_CARD_STATE]" & @CRLF & _
"[GprsGxService.onStart_UNSUITABLE_CARD_STATE]" & @CRLF & _
"[GprsGxService.onStart_UNSUITABLE_CARD_STATE]" & @CRLF & _
"[GprsGxService.onStop]" & @CRLF & _
"[GprsGxService.onStop]" & @CRLF & _
"[GprsGxService.onStop]" & @CRLF & _
"[GprsGxService.onStop_OK]" & @CRLF & _
"[GprsGxService.onStop_OK]" & @CRLF & _
"[GprsGxService.onStop_OK]" & @CRLF & _
"[GprsGxService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onUpdate]" & @CRLF & _
"[GprsGxService.onUpdate]" & @CRLF & _
"[GprsGxService.onUpdate]" & @CRLF & _
"[GprsGxService.onUpdate_ACCESS_DENIED]" & @CRLF & _
"[GprsGxService.onUpdate_ACCESS_DENIED]" & @CRLF & _
"[GprsGxService.onUpdate_ACCESS_DENIED]" & @CRLF & _
"[GprsGxService.onUpdate_FORCED_BREAK_SESSION]" & @CRLF & _
"[GprsGxService.onUpdate_FORCED_BREAK_SESSION]" & @CRLF & _
"[GprsGxService.onUpdate_FORCED_BREAK_SESSION]" & @CRLF & _
"[GprsGxService.onUpdate_NO_MONEY]" & @CRLF & _
"[GprsGxService.onUpdate_NO_MONEY]" & @CRLF & _
"[GprsGxService.onUpdate_NO_MONEY]" & @CRLF & _
"[GprsGxService.onUpdate_OK]" & @CRLF & _
"[GprsGxService.onUpdate_OK]" & @CRLF & _
"[GprsGxService.onUpdate_OK]" & @CRLF & _
"[GprsGxService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGxSession]" & @CRLF & _
"[GprsGxSession]" & @CRLF & _
"[GprsGxSession]" & @CRLF & _
"[GprsGyService.onStart]" & @CRLF & _
"[GprsGyService.onStart]" & @CRLF & _
"[GprsGyService.onStart]" & @CRLF & _
"[GprsGyService.onStart_ACCESS_DENIED]" & @CRLF & _
"[GprsGyService.onStart_ACCESS_DENIED]" & @CRLF & _
"[GprsGyService.onStart_ACCESS_DENIED]" & @CRLF & _
"[GprsGyService.onStart_CARD_NOT_FOUND]" & @CRLF & _
"[GprsGyService.onStart_CARD_NOT_FOUND]" & @CRLF & _
"[GprsGyService.onStart_CARD_NOT_FOUND]" & @CRLF & _
"[GprsGyService.onStart_GX_SESSION_NOT_FOUND]" & @CRLF & _
"[GprsGyService.onStart_GX_SESSION_NOT_FOUND]" & @CRLF & _
"[GprsGyService.onStart_GX_SESSION_NOT_FOUND]" & @CRLF & _
"[GprsGyService.onStart_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onStart_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onStart_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]" & @CRLF & _
"[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]" & @CRLF & _
"[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]" & @CRLF & _
"[GprsGyService.onStart_NO_MONEY]" & @CRLF & _
"[GprsGyService.onStart_NO_MONEY]" & @CRLF & _
"[GprsGyService.onStart_NO_MONEY]" & @CRLF & _
"[GprsGyService.onStart_OBJECT_BUSY]" & @CRLF & _
"[GprsGyService.onStart_OBJECT_BUSY]" & @CRLF & _
"[GprsGyService.onStart_OBJECT_BUSY]" & @CRLF & _
"[GprsGyService.onStart_OK]" & @CRLF & _
"[GprsGyService.onStart_OK]" & @CRLF & _
"[GprsGyService.onStart_OK]" & @CRLF & _
"[GprsGyService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGyService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGyService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGyService.onStart_SESSION_ALREADY_EXISTS]" & @CRLF & _
"[GprsGyService.onStart_SESSION_ALREADY_EXISTS]" & @CRLF & _
"[GprsGyService.onStart_SESSION_ALREADY_EXISTS]" & @CRLF & _
"[GprsGyService.onStop]" & @CRLF & _
"[GprsGyService.onStop]" & @CRLF & _
"[GprsGyService.onStop]" & @CRLF & _
"[GprsGyService.onStop_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onStop_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onStop_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onStop_OK]" & @CRLF & _
"[GprsGyService.onStop_OK]" & @CRLF & _
"[GprsGyService.onStop_OK]" & @CRLF & _
"[GprsGyService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onUpdate]" & @CRLF & _
"[GprsGyService.onUpdate]" & @CRLF & _
"[GprsGyService.onUpdate]" & @CRLF & _
"[GprsGyService.onUpdate_ACCESS_DENIED]" & @CRLF & _
"[GprsGyService.onUpdate_ACCESS_DENIED]" & @CRLF & _
"[GprsGyService.onUpdate_ACCESS_DENIED]" & @CRLF & _
"[GprsGyService.onUpdate_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onUpdate_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onUpdate_INTERNAL_ERROR]" & @CRLF & _
"[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]" & @CRLF & _
"[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]" & @CRLF & _
"[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]" & @CRLF & _
"[GprsGyService.onUpdate_NO_MONEY]" & @CRLF & _
"[GprsGyService.onUpdate_NO_MONEY]" & @CRLF & _
"[GprsGyService.onUpdate_NO_MONEY]" & @CRLF & _
"[GprsGyService.onUpdate_OBJECT_BUSY]" & @CRLF & _
"[GprsGyService.onUpdate_OBJECT_BUSY]" & @CRLF & _
"[GprsGyService.onUpdate_OBJECT_BUSY]" & @CRLF & _
"[GprsGyService.onUpdate_OK]" & @CRLF & _
"[GprsGyService.onUpdate_OK]" & @CRLF & _
"[GprsGyService.onUpdate_OK]" & @CRLF & _
"[GprsGyService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]" & @CRLF & _
"[GprsGyService.onUpdate_SESSION_NOT_FOUND]" & @CRLF & _
"[GprsGyService.onUpdate_SESSION_NOT_FOUND]" & @CRLF & _
"[GprsGyService.onUpdate_SESSION_NOT_FOUND]" & @CRLF & _
"[GprsGySession]" & @CRLF & _
"[GprsGySession]" & @CRLF & _
"[GprsGySession]" & @CRLF & _
"[Queue]" & @CRLF & _
"[Queue]" & @CRLF & _
"[Queue]" & @CRLF & _
"[SmsService.onCommit]" & @CRLF & _
"[SmsService.onCommit]" & @CRLF & _
"[SmsService.onCommit]" & @CRLF & _
"[SmsService.onCommit_OK]" & @CRLF & _
"[SmsService.onCommit_OK]" & @CRLF & _
"[SmsService.onCommit_OK]" & @CRLF & _
"[SmsService.onCommit_SERVER_OVERLOADED]" & @CRLF & _
"[SmsService.onCommit_SERVER_OVERLOADED]" & @CRLF & _
"[SmsService.onCommit_SERVER_OVERLOADED]" & @CRLF & _
"[SmsService.onRequest]" & @CRLF & _
"[SmsService.onRequest]" & @CRLF & _
"[SmsService.onRequest]" & @CRLF & _
"[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[SmsService.onRequest_CARD_NOT_FOUND]" & @CRLF & _
"[SmsService.onRequest_CARD_NOT_FOUND]" & @CRLF & _
"[SmsService.onRequest_CARD_NOT_FOUND]" & @CRLF & _
"[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]" & @CRLF & _
"[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]" & @CRLF & _
"[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]" & @CRLF & _
"[SmsService.onRequest_NO_MONEY]" & @CRLF & _
"[SmsService.onRequest_NO_MONEY]" & @CRLF & _
"[SmsService.onRequest_NO_MONEY]" & @CRLF & _
"[SmsService.onRequest_OK]" & @CRLF & _
"[SmsService.onRequest_OK]" & @CRLF & _
"[SmsService.onRequest_OK]" & @CRLF & _
"[SmsService.onRequest_SERVER_OVERLOADED]" & @CRLF & _
"[SmsService.onRequest_SERVER_OVERLOADED]" & @CRLF & _
"[SmsService.onRequest_SERVER_OVERLOADED]" & @CRLF & _
"[SmsService.onRequest_SERVICE_IS_BLOCKED]" & @CRLF & _
"[SmsService.onRequest_SERVICE_IS_BLOCKED]" & @CRLF & _
"[SmsService.onRequest_SERVICE_IS_BLOCKED]" & @CRLF & _
"[SmsService.onRequest_TARIFF_NOT_FOUND]" & @CRLF & _
"[SmsService.onRequest_TARIFF_NOT_FOUND]" & @CRLF & _
"[SmsService.onRequest_TARIFF_NOT_FOUND]" & @CRLF & _
"[SmsSession]" & @CRLF & _
"[SmsSession]" & @CRLF & _
"[SmsSession]" & @CRLF & _
"[VoiceService.onStart]" & @CRLF & _
"[VoiceService.onStart]" & @CRLF & _
"[VoiceService.onStart]" & @CRLF & _
"[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]" & @CRLF & _
"[VoiceService.onStart_NO_MONEY]" & @CRLF & _
"[VoiceService.onStart_NO_MONEY]" & @CRLF & _
"[VoiceService.onStart_NO_MONEY]" & @CRLF & _
"[VoiceService.onStart_OBJECT_BUSY]" & @CRLF & _
"[VoiceService.onStart_OBJECT_BUSY]" & @CRLF & _
"[VoiceService.onStart_OBJECT_BUSY]" & @CRLF & _
"[VoiceService.onStart_OK]" & @CRLF & _
"[VoiceService.onStart_OK]" & @CRLF & _
"[VoiceService.onStart_OK]" & @CRLF & _
"[VoiceService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceService.onStart_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[VoiceService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[VoiceService.onStart_SERVICE_IS_BLOCKED]" & @CRLF & _
"[VoiceService.onStart_TARIFF_NOT_FOUND]" & @CRLF & _
"[VoiceService.onStart_TARIFF_NOT_FOUND]" & @CRLF & _
"[VoiceService.onStart_TARIFF_NOT_FOUND]" & @CRLF & _
"[VoiceService.onStart_UNSUITABLE_CARD_STATE]" & @CRLF & _
"[VoiceService.onStart_UNSUITABLE_CARD_STATE]" & @CRLF & _
"[VoiceService.onStart_UNSUITABLE_CARD_STATE]" & @CRLF & _
"[VoiceService.onStop]" & @CRLF & _
"[VoiceService.onStop]" & @CRLF & _
"[VoiceService.onStop]" & @CRLF & _
"[VoiceService.onStop_OK]" & @CRLF & _
"[VoiceService.onStop_OK]" & @CRLF & _
"[VoiceService.onStop_OK]" & @CRLF & _
"[VoiceService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceService.onStop_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceService.onUpdate]" & @CRLF & _
"[VoiceService.onUpdate]" & @CRLF & _
"[VoiceService.onUpdate]" & @CRLF & _
"[VoiceService.onUpdate_OK]" & @CRLF & _
"[VoiceService.onUpdate_OK]" & @CRLF & _
"[VoiceService.onUpdate_OK]" & @CRLF & _
"[VoiceService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceService.onUpdate_SERVER_OVERLOADED]" & @CRLF & _
"[VoiceSession]" & @CRLF & _
"[VoiceSession]" & @CRLF & _
"[VoiceSession]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")