import Foundation
let pattern = #"([^[.]+)([.])([^_.]+)_"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[BillingFunctions.requestGprsTariff]
[BillingFunctions.requestGprsTariff]
[BillingFunctions.requestGprsTariff]
[BillingFunctions.requestSmsTariff]
[BillingFunctions.requestSmsTariff]
[BillingFunctions.requestSmsTariff]]
[BillingFunctions.requestVoiceTariff]
[BillingFunctions.requestVoiceTariff]
[BillingFunctions.requestVoiceTariff]
[GprsGxService.onStart]
[GprsGxService.onStart]
[GprsGxService.onStart]
[GprsGxService.onStart_ACCOUNT_NOT_FOUND]
[GprsGxService.onStart_ACCOUNT_NOT_FOUND]
[GprsGxService.onStart_ACCOUNT_NOT_FOUND]
[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]
[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]
[GprsGxService.onStart_CARD_ACTIVATED_IN_PROGRESS]
[GprsGxService.onStart_CARD_NOT_FOUND]
[GprsGxService.onStart_CARD_NOT_FOUND]
[GprsGxService.onStart_CARD_NOT_FOUND]
[GprsGxService.onStart_FAKE_NUMBER]
[GprsGxService.onStart_FAKE_NUMBER]
[GprsGxService.onStart_FAKE_NUMBER]
[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]
[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]
[GprsGxService.onStart_IMEI_NOT_MATCH_SPECIFIED]
[GprsGxService.onStart_INTERNAL_ERROR]
[GprsGxService.onStart_INTERNAL_ERROR]
[GprsGxService.onStart_INTERNAL_ERROR]
[GprsGxService.onStart_NO_MONEY]
[GprsGxService.onStart_NO_MONEY]
[GprsGxService.onStart_NO_MONEY]
[GprsGxService.onStart_OBJECT_BUSY]
[GprsGxService.onStart_OBJECT_BUSY]
[GprsGxService.onStart_OBJECT_BUSY]
[GprsGxService.onStart_OK]
[GprsGxService.onStart_OK]
[GprsGxService.onStart_OK]
[GprsGxService.onStart_SERVER_OVERLOADED]
[GprsGxService.onStart_SERVER_OVERLOADED]
[GprsGxService.onStart_SERVER_OVERLOADED]
[GprsGxService.onStart_SERVICE_IS_BLOCKED]
[GprsGxService.onStart_SERVICE_IS_BLOCKED]
[GprsGxService.onStart_SERVICE_IS_BLOCKED]
[GprsGxService.onStart_TARIFF_NOT_FOUND]
[GprsGxService.onStart_TARIFF_NOT_FOUND]
[GprsGxService.onStart_TARIFF_NOT_FOUND]
[GprsGxService.onStart_UNSUITABLE_CARD_STATE]
[GprsGxService.onStart_UNSUITABLE_CARD_STATE]
[GprsGxService.onStart_UNSUITABLE_CARD_STATE]
[GprsGxService.onStop]
[GprsGxService.onStop]
[GprsGxService.onStop]
[GprsGxService.onStop_OK]
[GprsGxService.onStop_OK]
[GprsGxService.onStop_OK]
[GprsGxService.onStop_SERVER_OVERLOADED]
[GprsGxService.onStop_SERVER_OVERLOADED]
[GprsGxService.onStop_SERVER_OVERLOADED]
[GprsGxService.onUpdate]
[GprsGxService.onUpdate]
[GprsGxService.onUpdate]
[GprsGxService.onUpdate_ACCESS_DENIED]
[GprsGxService.onUpdate_ACCESS_DENIED]
[GprsGxService.onUpdate_ACCESS_DENIED]
[GprsGxService.onUpdate_FORCED_BREAK_SESSION]
[GprsGxService.onUpdate_FORCED_BREAK_SESSION]
[GprsGxService.onUpdate_FORCED_BREAK_SESSION]
[GprsGxService.onUpdate_NO_MONEY]
[GprsGxService.onUpdate_NO_MONEY]
[GprsGxService.onUpdate_NO_MONEY]
[GprsGxService.onUpdate_OK]
[GprsGxService.onUpdate_OK]
[GprsGxService.onUpdate_OK]
[GprsGxService.onUpdate_SERVER_OVERLOADED]
[GprsGxService.onUpdate_SERVER_OVERLOADED]
[GprsGxService.onUpdate_SERVER_OVERLOADED]
[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]
[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]
[GprsGxService.onUpdate_SERVICE_IS_BLOCKED]
[GprsGxSession]
[GprsGxSession]
[GprsGxSession]
[GprsGyService.onStart]
[GprsGyService.onStart]
[GprsGyService.onStart]
[GprsGyService.onStart_ACCESS_DENIED]
[GprsGyService.onStart_ACCESS_DENIED]
[GprsGyService.onStart_ACCESS_DENIED]
[GprsGyService.onStart_CARD_NOT_FOUND]
[GprsGyService.onStart_CARD_NOT_FOUND]
[GprsGyService.onStart_CARD_NOT_FOUND]
[GprsGyService.onStart_GX_SESSION_NOT_FOUND]
[GprsGyService.onStart_GX_SESSION_NOT_FOUND]
[GprsGyService.onStart_GX_SESSION_NOT_FOUND]
[GprsGyService.onStart_INTERNAL_ERROR]
[GprsGyService.onStart_INTERNAL_ERROR]
[GprsGyService.onStart_INTERNAL_ERROR]
[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]
[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]
[GprsGyService.onStart_INVALID_TARIFF_CONFIGURATION]
[GprsGyService.onStart_NO_MONEY]
[GprsGyService.onStart_NO_MONEY]
[GprsGyService.onStart_NO_MONEY]
[GprsGyService.onStart_OBJECT_BUSY]
[GprsGyService.onStart_OBJECT_BUSY]
[GprsGyService.onStart_OBJECT_BUSY]
[GprsGyService.onStart_OK]
[GprsGyService.onStart_OK]
[GprsGyService.onStart_OK]
[GprsGyService.onStart_SERVER_OVERLOADED]
[GprsGyService.onStart_SERVER_OVERLOADED]
[GprsGyService.onStart_SERVER_OVERLOADED]
[GprsGyService.onStart_SERVICE_IS_BLOCKED]
[GprsGyService.onStart_SERVICE_IS_BLOCKED]
[GprsGyService.onStart_SERVICE_IS_BLOCKED]
[GprsGyService.onStart_SESSION_ALREADY_EXISTS]
[GprsGyService.onStart_SESSION_ALREADY_EXISTS]
[GprsGyService.onStart_SESSION_ALREADY_EXISTS]
[GprsGyService.onStop]
[GprsGyService.onStop]
[GprsGyService.onStop]
[GprsGyService.onStop_INTERNAL_ERROR]
[GprsGyService.onStop_INTERNAL_ERROR]
[GprsGyService.onStop_INTERNAL_ERROR]
[GprsGyService.onStop_OK]
[GprsGyService.onStop_OK]
[GprsGyService.onStop_OK]
[GprsGyService.onStop_SERVER_OVERLOADED]
[GprsGyService.onStop_SERVER_OVERLOADED]
[GprsGyService.onStop_SERVER_OVERLOADED]
[GprsGyService.onUpdate]
[GprsGyService.onUpdate]
[GprsGyService.onUpdate]
[GprsGyService.onUpdate_ACCESS_DENIED]
[GprsGyService.onUpdate_ACCESS_DENIED]
[GprsGyService.onUpdate_ACCESS_DENIED]
[GprsGyService.onUpdate_INTERNAL_ERROR]
[GprsGyService.onUpdate_INTERNAL_ERROR]
[GprsGyService.onUpdate_INTERNAL_ERROR]
[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]
[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]
[GprsGyService.onUpdate_INVALID_TARIFF_CONFIGURATION]
[GprsGyService.onUpdate_NO_MONEY]
[GprsGyService.onUpdate_NO_MONEY]
[GprsGyService.onUpdate_NO_MONEY]
[GprsGyService.onUpdate_OBJECT_BUSY]
[GprsGyService.onUpdate_OBJECT_BUSY]
[GprsGyService.onUpdate_OBJECT_BUSY]
[GprsGyService.onUpdate_OK]
[GprsGyService.onUpdate_OK]
[GprsGyService.onUpdate_OK]
[GprsGyService.onUpdate_SERVER_OVERLOADED]
[GprsGyService.onUpdate_SERVER_OVERLOADED]
[GprsGyService.onUpdate_SERVER_OVERLOADED]
[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]
[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]
[GprsGyService.onUpdate_SERVICE_IS_BLOCKED]
[GprsGyService.onUpdate_SESSION_NOT_FOUND]
[GprsGyService.onUpdate_SESSION_NOT_FOUND]
[GprsGyService.onUpdate_SESSION_NOT_FOUND]
[GprsGySession]
[GprsGySession]
[GprsGySession]
[Queue]
[Queue]
[Queue]
[SmsService.onCommit]
[SmsService.onCommit]
[SmsService.onCommit]
[SmsService.onCommit_OK]
[SmsService.onCommit_OK]
[SmsService.onCommit_OK]
[SmsService.onCommit_SERVER_OVERLOADED]
[SmsService.onCommit_SERVER_OVERLOADED]
[SmsService.onCommit_SERVER_OVERLOADED]
[SmsService.onRequest]
[SmsService.onRequest]
[SmsService.onRequest]
[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]
[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]
[SmsService.onRequest_CARD_ACTIVATED_IN_PROGRESS]
[SmsService.onRequest_CARD_NOT_FOUND]
[SmsService.onRequest_CARD_NOT_FOUND]
[SmsService.onRequest_CARD_NOT_FOUND]
[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]
[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]
[SmsService.onRequest_IMEI_NOT_MATCH_SPECIFIED]
[SmsService.onRequest_NO_MONEY]
[SmsService.onRequest_NO_MONEY]
[SmsService.onRequest_NO_MONEY]
[SmsService.onRequest_OK]
[SmsService.onRequest_OK]
[SmsService.onRequest_OK]
[SmsService.onRequest_SERVER_OVERLOADED]
[SmsService.onRequest_SERVER_OVERLOADED]
[SmsService.onRequest_SERVER_OVERLOADED]
[SmsService.onRequest_SERVICE_IS_BLOCKED]
[SmsService.onRequest_SERVICE_IS_BLOCKED]
[SmsService.onRequest_SERVICE_IS_BLOCKED]
[SmsService.onRequest_TARIFF_NOT_FOUND]
[SmsService.onRequest_TARIFF_NOT_FOUND]
[SmsService.onRequest_TARIFF_NOT_FOUND]
[SmsSession]
[SmsSession]
[SmsSession]
[VoiceService.onStart]
[VoiceService.onStart]
[VoiceService.onStart]
[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]
[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]
[VoiceService.onStart_CARD_ACTIVATED_IN_PROGRESS]
[VoiceService.onStart_NO_MONEY]
[VoiceService.onStart_NO_MONEY]
[VoiceService.onStart_NO_MONEY]
[VoiceService.onStart_OBJECT_BUSY]
[VoiceService.onStart_OBJECT_BUSY]
[VoiceService.onStart_OBJECT_BUSY]
[VoiceService.onStart_OK]
[VoiceService.onStart_OK]
[VoiceService.onStart_OK]
[VoiceService.onStart_SERVER_OVERLOADED]
[VoiceService.onStart_SERVER_OVERLOADED]
[VoiceService.onStart_SERVER_OVERLOADED]
[VoiceService.onStart_SERVICE_IS_BLOCKED]
[VoiceService.onStart_SERVICE_IS_BLOCKED]
[VoiceService.onStart_SERVICE_IS_BLOCKED]
[VoiceService.onStart_TARIFF_NOT_FOUND]
[VoiceService.onStart_TARIFF_NOT_FOUND]
[VoiceService.onStart_TARIFF_NOT_FOUND]
[VoiceService.onStart_UNSUITABLE_CARD_STATE]
[VoiceService.onStart_UNSUITABLE_CARD_STATE]
[VoiceService.onStart_UNSUITABLE_CARD_STATE]
[VoiceService.onStop]
[VoiceService.onStop]
[VoiceService.onStop]
[VoiceService.onStop_OK]
[VoiceService.onStop_OK]
[VoiceService.onStop_OK]
[VoiceService.onStop_SERVER_OVERLOADED]
[VoiceService.onStop_SERVER_OVERLOADED]
[VoiceService.onStop_SERVER_OVERLOADED]
[VoiceService.onUpdate]
[VoiceService.onUpdate]
[VoiceService.onUpdate]
[VoiceService.onUpdate_OK]
[VoiceService.onUpdate_OK]
[VoiceService.onUpdate_OK]
[VoiceService.onUpdate_SERVER_OVERLOADED]
[VoiceService.onUpdate_SERVER_OVERLOADED]
[VoiceService.onUpdate_SERVER_OVERLOADED]
[VoiceSession]
[VoiceSession]
[VoiceSession]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)