re = /(?s)\([^(]*\((.+)\)[^)]*\)/m
str = 'hello ((
(alpha123_4rf)
45beta_Frank))
Red5Great_Sam_Fun'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end