using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\w\*]+(\s)*?){2,4}\(([^!@#$+%^;]*?)\)\s*{";
string input = @"int test()
{
int test(int a) {
int test(int a, int b){
int test(int a,int b) {
_int _test(string * b){
int test (string b)
{
int test (string b) {
int
b
(int a)
{
test:
int test();
static int main(){
_static _void _itnt * main(){
static timerr iftnst
([A-z_]+\ *){3}(\(.*\))
Copyright (C) Stefan Frings";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}