// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\w\*]+(\s)*?){2,4}\(([^!@#$+%^;]*?)\)\s*{").unwrap();
let string = "int test()
{
int test(int a) {
int test(int a, int b){
int test(int a,int b) {
_int _test(string * b){
int test (string b)
{
int test (string b) {
int
b
(int a)
{
test:
int test();
static int main(){
_static _void _itnt * main(){
static timerr iftnst
([A-z_]+\\ *){3}(\\(.*\\))
Copyright (C) Stefan Frings";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}