re = /(?=(?:(.)(?!\1)|^)((.)\3{2})(?!\3))/m
str = 'aaaaabbbcccccccccdddee
aaabbbcccdddeee'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end