re = /Location\[gps (-?\d+(?:\.\d+)?),(-?\d+(?:\.\d+)?)/m
str = 'location: Location[gps 39.549497,-120.328997 hAcc=20 et=+44m40s745ms alt=0.0 vel=0.0 bear=0.0 vAcc=??? sAcc=??? bAcc=??? {Bundle[mParcelledData.dataSize=96]}]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end